Service Health

View the current and historical status of Ropo services.

A disruption in delivering e-invoices and business messages from Ropo to OpenText

Minor incident Ropo Finland Invoice delivery
2025-01-22 15:54 EET · 17 hours, 19 minutes

Updates

Resolved

The issue has been resolved, and the service is operating normally again.

January 23, 2025 · 09:11 EET
Issue

There was a disruption in the transmission of e-invoices and business messages from Ropo to OpenText, which delayed the delivery of materials between January 18 and 22, 2025. The issue has now been resolved, and the service is operating normally again.

We apologize for any inconvenience this disruption may have caused.

January 22, 2025 · 15:54 EET

← Back