Service Health

View the current and historical status of Ropo services.

Logging into MyRopo via OP's identification service is currently not possible

Minor incident Ropo Finland Customer services
2025-01-27 09:48 EET · 1 day, 50 minutes

Updates

Resolved

Logging into MyRopo via OP’s identification service is working normally again.

Ropo | Communications
www.ropo.fi

January 28, 2025 · 10:36 EET
Investigating

Logging into MyRopo via OP’s identification service is currently not possible. We are currently investigating the issue.

Ropo | Communications
www.ropo.fi

January 27, 2025 · 09:48 EET

← Back