Service Health

View the current and historical status of Ropo services.

Logging into MyRopo via S-Bank's identification service is currently not possible

Minor incident Ropo Finland Customer services
2025-03-13 12:59 EET · 1 day, 52 minutes

Updates

Resolved

Logging into MyRopo via S-Banks’s identification service is working normally again.

Ropo | Communications

March 14, 2025 · 12:00 EET
Investigating

Logging into MyRopo via S-Bank’s identification service is currently not possible. We are currently investigating the issue.

Ropo | Communications

March 13, 2025 · 12:59 EET

← Back