Missing Payment Files - May 6, 2025
Minor incident
Ropo Sweden
Bank and monetary transactions
2025-05-06 11:28 EEST
· 22 hours, 9 minutes
Updates
Resolved
May 7, 2025 · 09:34 EEST
Dear Customer,
The payments from yesterday have been successfully transferred to you. We apologize for any inconvenience this may have caused.
If you have any questions, please don’t hesitate to contact us using the details below:
Email: klientsupport@ropo.com
Phone: +46 10 204 57 63
Issue
May 6, 2025 · 11:28 EEST
Dear Customer,
Unfortunately, we did not receive any payment files from our bank in time today. This means that today’s payments will not be transferred to you until tomorrow. We apologize for the delay.
If you have any questions, please contact us using the details below:
Email: klientsupport@ropo.com
Phone: +46 10 204 57 63
← Back