Service Health

View the current and historical status of Ropo services.

Disruption in payment data creation – settlements are delayed

Minor incident Ropo Finland Bank and monetary transactions Aktia Danske Bank Nordea OP SEB Säästöpankki
2025-06-09 09:43 EEST · 6 hours, 19 minutes

Updates

Resolved

The disruption detected in the creation of payment files has been resolved, and all payments have now been remitted to our clients.

We apologize for any inconvenience the disruption may have caused.

Ropo | Communications

June 9, 2025 · 16:01 EEST
Investigating

The disruption detected in the creation of payment files continues to affect payments received in Ropo’s Osuuspankki account. All other payments have been successfully processed today.

We are continuing to investigate the cause of the disruption and will provide an update as soon as the issue has been resolved and all payments have been processed.

Ropo | Communications

June 9, 2025 · 15:08 EEST
Issue

A disruption has been detected in the creation of payment files, which is causing delays in the processing of today’s payments.

We are currently investigating the cause of the disruption and will provide an update as soon as the issue is resolved.

Ropo | Communications

June 9, 2025 · 09:43 EEST

← Back