Service Health

View the current and historical status of Ropo services.

Disruptions in Payment Files - 17th of June, 2025

Minor incident Ropo Sweden Bank and monetary transactions
2025-06-17 11:08 EEST · 1 day, 16 minutes

Updates

Resolved

Dear Customer.

The disruptions that occurred in the payment files have now been resolved.
This means that the payment files have been sent, or will be sent to you shortly. If you have received your payment files as usual, you may disregard this message.

We apologize for the delay and thank you for your patience.

If you have any questions, please contact us using the details below or reach out to your nearest contact person.

Email: klientsupport@ropo.com
Phone: +46 10 204 57 63

June 18, 2025 · 11:20 EEST
Issue

Dear Customer,

We are unfortunately experiencing disruptions in our payment files. This means that some payments may be delayed. If you have received your payment files as usual, you can disregard this message.

We apologize for the delay and are actively working to resolve the issue and keep you updated.

If you have any questions, please contact us using the details below or reach out to your nearest contact person.

Email: klientsupport@ropo.com
Phone: +46 10 204 57 63

June 17, 2025 · 11:08 EEST

← Back