Service Health

View the current and historical status of Ropo services.

Nordea service disruption delayed e‑invoice delivery to S‑Bank and Ålandsbanken

Minor incident Ropo Finland Invoice delivery
2026-03-10 15:38 EET · 5 days, 18 hours, 25 minutes

Updates

Resolved

We have contacted the clients whose invoices were affected by the delay and made the necessary due date corrections in Ropo One.

The situation does not require any action from our clients.

Ropo | Communication

March 16, 2026 · 09:59 EET
Issue

Nordea service disruption delayed e‑invoice delivery to S‑Bank and Ålandsbanken

A service disruption in Nordea has caused some e‑invoices sent on 24–25 February 2026 to be delivered to S‑Bank and Ålandsbanken later than usual. The affected invoices were delivered to these banks between 7 and 10 March 2026.

As a result of the delay, error notifications indicating that the due date is in the past may appear in Ropo One until 12 March 2026.

No action is required from our clients. Ropo will correct the due date errors centrally once all error notifications have been received. Once the full scope of the disruption is known, we will contact separately those clients whose sent invoices are affected.

We apologize for any inconvenience this disruption may have caused.

Ropo | Communication

March 10, 2026 · 15:38 EET

← Back