Service Health

View the current and historical status of Ropo services.

POP Bank disruption affecting data retrieval

Minor incident Ropo Finland Invoice delivery
2026-06-03 14:46 EEST · 1 week, 4 days, 19 hours, 34 minutes

Updates

Resolved

The disruption in data retrieval from POP Bank ended on Friday, June 12. All files have now been successfully retrieved, and the service is operating normally again.

Ropo | Communication

June 15, 2026 · 10:19 EEST
Investigating

There is currently a disruption at POP Bank that prevents the retrieval of electronic purchase invoices and error feedback for b2b e-invoices from POP Bank.

We are actively investigating the issue together with the bank. You can follow the progress of the disruption on our Service Health page (https://status.ropo.com/), where we will post the latest updates as the situation evolves.

Ropo | Communications

June 3, 2026 · 14:46 EEST

← Back